CRAN Package Check Results for Package fastrtext

Last updated on 2019-08-25 01:47:14 CEST.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 0.3.3 117.89 208.46 326.35 WARN
r-devel-linux-x86_64-debian-gcc 0.3.3 85.28 187.54 272.82 WARN
r-devel-linux-x86_64-fedora-clang 0.3.3 394.89 WARN
r-devel-linux-x86_64-fedora-gcc 0.3.3 389.17 WARN
r-devel-windows-ix86+x86_64 0.3.3 239.00 216.00 455.00 WARN
r-patched-linux-x86_64 0.3.3 99.68 210.29 309.97 OK
r-patched-solaris-x86 0.3.3 704.20 OK
r-release-linux-x86_64 0.3.3 99.07 210.28 309.35 OK
r-release-windows-ix86+x86_64 0.3.3 243.00 186.00 429.00 OK
r-release-osx-x86_64 0.3.3 NOTE
r-oldrel-windows-ix86+x86_64 0.3.3 326.00 173.00 499.00 OK
r-oldrel-osx-x86_64 0.3.3 NOTE

Check Details

Version: 0.3.3
Check: whether package can be installed
Result: WARN
    Found the following significant warnings:
     fasttext/fasttext.cc:323:16: warning: 'selectEmbeddings' is deprecated: selectEmbeddings is being deprecated. [-Wdeprecated-declarations]
     fasttext/fasttext.cc:551:5: warning: 'precomputeWordVectors' is deprecated: precomputeWordVectors is being deprecated. [-Wdeprecated-declarations]
Flavors: r-devel-linux-x86_64-debian-clang, r-devel-linux-x86_64-fedora-clang

Version: 0.3.3
Check: whether package can be installed
Result: WARN
    Found the following significant warnings:
     fasttext/fasttext.cc:323:45: warning: ‘std::vector<int> fasttext::FastText::selectEmbeddings(int32_t) const’ is deprecated: selectEmbeddings is being deprecated. [-Wdeprecated-declarations]
     fasttext/fasttext.cc:551:40: warning: ‘void fasttext::FastText::precomputeWordVectors(fasttext::DenseMatrix&)’ is deprecated: precomputeWordVectors is being deprecated. [-Wdeprecated-declarations]
Flavors: r-devel-linux-x86_64-debian-gcc, r-devel-linux-x86_64-fedora-gcc

Version: 0.3.3
Check: installed package size
Result: NOTE
     installed size is 8.3Mb
     sub-directories of 1Mb or more:
     extdata 2.0Mb
     libs 5.9Mb
Flavors: r-devel-linux-x86_64-fedora-clang, r-release-osx-x86_64, r-oldrel-osx-x86_64

Version: 0.3.3
Check: whether package can be installed
Result: WARN
    Found the following significant warnings:
     fasttext/fasttext.cc:323:45: warning: 'std::vector<int> fasttext::FastText::selectEmbeddings(int32_t) const' is deprecated (declared at fasttext/fasttext.cc:293): selectEmbeddings is being deprecated. [-Wdeprecated-declarations]
     fasttext/fasttext.cc:551:40: warning: 'void fasttext::FastText::precomputeWordVectors(fasttext::DenseMatrix&)' is deprecated (declared at fasttext/fasttext.cc:534): precomputeWordVectors is being deprecated. [-Wdeprecated-declarations]
Flavor: r-devel-windows-ix86+x86_64